Failed to get account clusters during build

When a pipeline is running, Codefresh automatically sets up several environment variables that are available to all pipeline steps.

For Kubernetes clusters, if you have configured at least one cluster, the KUBECONFIG environment variable, containing the path to the kubeconfig file will become available in the pipeline.

For more information about the KUBECONFIG environment variable, see the official Kubernetes documentation.

Possible cause

If your Kubernetes cluster appears in the Codefresh Dashboard (IntegrationsKubernetesConfigure) but is not accessible in a pipeline, then maybe:

  • The cluster is not accessible anymore via Codefresh. Try running kubectl get node -owide in your cloud shell to see the status of the nodes.
  • The cluster has been deleted externally.

Solution

Contact us via the Intercom window on the bottom right of the Codefresh interface for additional assistance.

Troubleshooting common issues